Loyola University Chicago

Instructional Technology & Research Support

Information Technology Services

Browser FAQ

Sakai CLE is designed to work with modern browsers. Use the latest versions of Firefox (Mozilla), Safari (Apple), Chrome (Google), and IE 9 (Microsoft Internet Explorer aka IE) and IE 8. Sakai does not work with IE 7 and earlier, or with Firefox 10 and earlier.  For more information, visit https://confluence.sakaiproject.org/display/DOC/Sakai+10+Browser+Support

Browser Version


Each browser interprets a website  in a slightly different manner, which means that it may appear differently using different browser versions. It is important to keep your browser up-to-date to be able to access newer features. Also note that often older versions are no longer supported.

 

Quick check of this browser

 

Instructions to view a browser's version

Clearing your Cache

Your browser's cache stores temporary internet files that have been picked up from your web browsing activities. The cache houses information regarding sites you have visited, images and music you may have downloaded, etc. By storing this information, caches allow your browser to display web pages that you have previously visited. However, it is important to clear your cache from time to time in order to clear out any stored data.


Instructions to clearing the cache

 

 

 Allowing Pop-ups

Pop-up are small windows that apper on your screen. If you are trying to view content that requires a pop-up you will need to turn off your pop-up blocker before you are able to view the content.

 

Instructions to allowing pop-ups